import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\\b.{11}\\b)[0-9]{1,4}\\/[0-9]{1,4}\\/[0-9]{1,4}";
final String string = "12/3456/789\n"
+ "123/4567/89\n"
+ "1234/5/6789\n"
+ "123/456/789\n"
+ "12/3456/7890";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}