const regex = /(?=\b.{11}\b)[0-9]{1,4}\/[0-9]{1,4}\/[0-9]{1,4}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\b.{11}\\b)[0-9]{1,4}\\\/[0-9]{1,4}\\\/[0-9]{1,4}', 'g')
const str = `12/3456/789
123/4567/89
1234/5/6789
123/456/789
12/3456/7890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}