import re
regex = re.compile(r"(?=\b.{11}\b)[0-9]{1,4}\/[0-9]{1,4}\/[0-9]{1,4}")
test_str = ("12/3456/789\n"
"123/4567/89\n"
"1234/5/6789\n"
"123/456/789\n"
"12/3456/7890")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")