package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:ds1\-uk\-rules\-[1-3]|fh\-uk11)\.mailshell\.net$`)
var str = `ds1-uk-rules-1.mailshell.net
ds1-uk-rules-2.mailshell.net
ds1-uk-rules-3.mailshell.net
fh-uk11.mailshell.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}