import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:ds1\\-uk\\-rules\\-[1-3]|fh\\-uk11)\\.mailshell\\.net$";
final String string = "ds1-uk-rules-1.mailshell.net\n"
+ "ds1-uk-rules-2.mailshell.net\n"
+ "ds1-uk-rules-3.mailshell.net\n"
+ "fh-uk11.mailshell.net";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}