const regex = /^(?:ds1\-uk\-rules\-[1-3]|fh\-uk11)\.mailshell\.net$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:ds1\\-uk\\-rules\\-[1-3]|fh\\-uk11)\\.mailshell\\.net$', 'gmi')
const str = `ds1-uk-rules-1.mailshell.net
ds1-uk-rules-2.mailshell.net
ds1-uk-rules-3.mailshell.net
fh-uk11.mailshell.net`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}