package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?[0-9]\d*(\.\d+)?$`)
var str = `10.00
10
59
-56.15
-77,55
-30
+10.500
Text
-Text
50Abe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}