$re = '/^[-+]?[0-9]\d*(\.\d+)?$/m';
$str = '10.00
10
59
-56.15
-77,55
-30
+10.500
Text
-Text
50Abe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);