import re
regex = re.compile(r"^[-+]?[0-9]\d*(\.\d+)?$", flags=re.MULTILINE)
test_str = ("10.00\n"
"10\n"
"59\n"
"-56.15\n"
"-77,55\n"
"-30\n"
"+10.500\n"
"Text\n"
"-Text\n"
"50Abe")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")