re = /^[-+]?[0-9]\d*(\.\d+)?$/m
str = '10.00
10
59
-56.15
-77,55
-30
+10.500
Text
-Text
50Abe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end