using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^. \n]*\.)(?=(?:[^X \n]*X){4}).{5}$";
string input = @"XX.XX
XXXXX
XXXX.
X.X.X
.XXXX
.....
X..XX
abc.XXXX
XX.XabcX
XXX.X";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}