$re = '/^(?=[^. \n]*\.)(?=(?:[^X \n]*X){4}).{5}$/m';
$str = 'XX.XX
XXXXX
XXXX.
X.X.X
.XXXX
.....
X..XX
abc.XXXX
XX.XabcX
XXX.X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);