import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^. \\n]*\\.)(?=(?:[^X \\n]*X){4}).{5}$";
final String string = "XX.XX\n"
+ "XXXXX\n"
+ "XXXX.\n"
+ "X.X.X\n"
+ ".XXXX\n"
+ ".....\n"
+ "X..XX\n"
+ "abc.XXXX\n"
+ "XX.XabcX\n"
+ "XXX.X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}