import re
regex = re.compile(r"^(?=[^. \n]*\.)(?=(?:[^X \n]*X){4}).{5}$", flags=re.MULTILINE)
test_str = ("XX.XX\n"
"XXXXX\n"
"XXXX.\n"
"X.X.X\n"
".XXXX\n"
".....\n"
"X..XX\n"
"abc.XXXX\n"
"XX.XabcX\n"
"XXX.X")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")