const regex = /[\]\[\s]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\]\\[\\s]+', 'gm')
const str = `[one] [two] [three] 1234567890ABC`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);