re = /[\]\[\s]+/m
str = '[one] [two] [three] 1234567890ABC'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result