$re = '/[\]\[\s]+/m';
$str = '[one] [two] [three] 1234567890ABC';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;