use strict;
my $str = '[one] [two] [three] 1234567890ABC';
my $regex = qr/[\]\[\s]+/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";