#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?m)^Computer\r?\n.+\r?\n(?:fPromptForPassword|AllowLocalPolicyMerge|AllowLocalIPsecPolicyMerge)\r?\n.+(?:\r?\n)?"
Local $sString = "one" & @CRLF & _
"---" & @CRLF & _
"Computer" & @CRLF & _
"Software\Policies" & @CRLF & _
"fPromptForPassword" & @CRLF & _
"DWORD:1" & @CRLF & _
"---" & @CRLF & _
"two" & @CRLF & _
"---" & @CRLF & _
"Computer" & @CRLF & _
"Software\Policies" & @CRLF & _
"AllowLocalIPsecPolicyMerge" & @CRLF & _
"DWORD:1" & @CRLF & _
"---" & @CRLF & _
"three" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")