package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?m)^Computer\r?\n.+\r?\n(?:fPromptForPassword|AllowLocalPolicyMerge|AllowLocalIPsecPolicyMerge)\r?\n.+(?:\r?\n)?`)
var str = `one
---
Computer
Software\Policies
fPromptForPassword
DWORD:1
---
two
---
Computer
Software\Policies
AllowLocalIPsecPolicyMerge
DWORD:1
---
three
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}