import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^Computer\\r?\\n.+\\r?\\n(?:fPromptForPassword|AllowLocalPolicyMerge|AllowLocalIPsecPolicyMerge)\\r?\\n.+(?:\\r?\\n)?";
final String string = "one\n"
+ "---\n"
+ "Computer\n"
+ "Software\\Policies\n"
+ "fPromptForPassword\n"
+ "DWORD:1\n"
+ "---\n"
+ "two\n"
+ "---\n"
+ "Computer\n"
+ "Software\\Policies\n"
+ "AllowLocalIPsecPolicyMerge\n"
+ "DWORD:1\n"
+ "---\n"
+ "three\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}