$re = '/(?m)^Computer\r?\n.+\r?\n(?:fPromptForPassword|AllowLocalPolicyMerge|AllowLocalIPsecPolicyMerge)\r?\n.+(?:\r?\n)?/mi';
$str = 'one
---
Computer
Software\\Policies
fPromptForPassword
DWORD:1
---
two
---
Computer
Software\\Policies
AllowLocalIPsecPolicyMerge
DWORD:1
---
three
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);