# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[#$@]\w+\b(?!\W*\s\w)//gm;t' <<< "The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX @foo > $MUTE $ETH $BTC #BTC"