const regex = /[#$@]\w+\b(?!\W*\s\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[#$@]\\w+\\b(?!\\W*\\s\\w)', 'gm')
const str = `The moment #BTC, we have all \$BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. \$NBT > \$VOICE \$NIX @foo > \$MUTE \$ETH \$BTC #BTC`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);