re = /[#$@]\w+\b(?!\W*\s\w)/m
str = 'The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX @foo > $MUTE $ETH $BTC #BTC'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result