$re = '/[#$@]\w+\b(?!\W*\s\w)/m';
$str = 'The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX @foo > $MUTE $ETH $BTC #BTC';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;