using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[Rr](?:ef|eference)? +([$.@\w\d]+) *-> *(.*)$";
string input = @"ref aku -> a $1 v 3
ref aku -> List $1 r 3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}