re = /^[Rr](?:ef|eference)? +([$.@\w\d]+) *-> *(.*)$/m
str = 'ref aku -> a $1 v 3
ref aku -> List $1 r 3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end