$re = '/^[Rr](?:ef|eference)? +([$.@\w\d]+) *-> *(.*)$/m';
$str = 'ref aku -> a $1 v 3
ref aku -> List $1 r 3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);