package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[Rr](?:ef|eference)? +([$.@\w\d]+) *-> *(.*)$`)
var str = `ref aku -> a $1 v 3
ref aku -> List $1 r 3
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}