package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(the )?colou?rs? gr[ae]y`)
var str = `color gray
The colours grey and blue
It's in the color gray`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}