import re
regex = re.compile(r"^(the )?colou?rs? gr[ae]y", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("color gray\n"
"The colours grey and blue\n"
"It's in the color gray")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")