$re = '/^(the )?colou?rs? gr[ae]y/im';
$str = 'color gray
The colours grey and blue
It\'s in the color gray';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);