re = /^(the )?colou?rs? gr[ae]y/im
str = 'color gray
The colours grey and blue
It\'s in the color gray'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end