package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)GO_VERSION[\s\S]+"(?<currentValue>.+)"`)
var str = `[build.environment]
GO_VERSION = "1.22.2"
HUGO_VERSION = "0.126.0"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}