// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)GO_VERSION[\s\S]+"(?<currentValue>.+)""#).unwrap();
let string = "[build.environment]
GO_VERSION = \"1.22.2\"
HUGO_VERSION = \"0.126.0\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}