$re = '/GO_VERSION[\s\S]+"(?<currentValue>.+)"/m';
$str = '[build.environment]
GO_VERSION = "1.22.2"
HUGO_VERSION = "0.126.0"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);