import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "GO_VERSION[\\s\\S]+\"(?<currentValue>.+)\"";
final String string = "[build.environment]\n"
+ "GO_VERSION = \"1.22.2\"\n"
+ "HUGO_VERSION = \"0.126.0\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}