using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-zÀ-ú]{3,} [A-zÀ-ú]{3,}.*";
string input = @"Luck Skywalker Darth Vader Son
Maria da Mata
Reinaldo D'avila
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}