package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-zÀ-ú]{3,} [A-zÀ-ú]{3,}.*`)
var str = `Luck Skywalker Darth Vader Son
Maria da Mata
Reinaldo D'avila
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}