re = /^[A-zÀ-ú]{3,} [A-zÀ-ú]{3,}.*/m
str = 'Luck Skywalker Darth Vader Son
Maria da Mata
Reinaldo D\'avila
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end