$re = '/^[A-zÀ-ú]{3,} [A-zÀ-ú]{3,}.*/m';
$str = 'Luck Skywalker Darth Vader Son
Maria da Mata
Reinaldo D\'avila
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);