import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{Extended_Pictographic}+$";
final String string = "πΊπΈdπΈπ©πΌββ€οΈβπβπ©π½f\n"
+ "t\n"
+ "3\n"
+ "πΊπΈπΈπ©πΌ\n"
+ "β€οΈ\n"
+ "π\n"
+ "π³ββοΈ\n"
+ "π\n"
+ "π";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}