// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^\p{Extended_Pictographic}+$").unwrap();
let string = "πΊπΈdπΈπ©πΌββ€οΈβπβπ©π½f
t
3
πΊπΈπΈπ©πΌ
β€οΈ
π
π³ββοΈ
π
π";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}