import re
regex = re.compile(r"^\p{Extended_Pictographic}+$", flags=re.MULTILINE | re.UNICODE)
test_str = ("πΊπΈdπΈπ©πΌββ€οΈβπβπ©π½f\n"
"t\n"
"3\n"
"πΊπΈπΈπ©πΌ\n"
"β€οΈ\n"
"π\n"
"π³ββοΈ\n"
"π\n"
"π")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")