const regex = /^\p{Extended_Pictographic}+$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\p{Extended_Pictographic}+$', 'gmu')
const str = `πΊπΈdπΈπ©πΌββ€οΈβπβπ©π½f
t
3
πΊπΈπΈπ©πΌ
β€οΈ
π
π³ββοΈ
π
π`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}