using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(apple|bat|car), (?!\1)(apple|bat|car), (?!\1|\2)(apple|bat|car)$";
string input = @"apple, bat, car
apple, car, bat
bat, apple, car
car, bat, apple
FAILS
apple, bat, car, d
d, apple, bat, car
apple, bat, d, car
apple, apple, car
apple, apple, apple";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}