const regex = /^(apple|bat|car), (?!\1)(apple|bat|car), (?!\1|\2)(apple|bat|car)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(apple|bat|car), (?!\\1)(apple|bat|car), (?!\\1|\\2)(apple|bat|car)$', 'gmi')
const str = `apple, bat, car
apple, car, bat
bat, apple, car
car, bat, apple
FAILS
apple, bat, car, d
d, apple, bat, car
apple, bat, d, car
apple, apple, car
apple, apple, apple`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}