re = /^(apple|bat|car), (?!\1)(apple|bat|car), (?!\1|\2)(apple|bat|car)$/mi
str = 'apple, bat, car
apple, car, bat
bat, apple, car
car, bat, apple
FAILS
apple, bat, car, d
d, apple, bat, car
apple, bat, d, car
apple, apple, car
apple, apple, apple'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end