package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((<style>)|(<style\s+type=(?:".*"|'.*')\/?)|(<\/style>))`)
var str = `<style>
<style type='text/css'/>
<style type="text/css">
styles
</style>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}